Resolving Sync Problems in OneDrive

Sometimes, OneDrive Sync Client has trouble syncing files. This article will walk you through diagnosing the issues with your files, and then resolving them.

Diagnosis

There's a few reasons you might discover that your files are having trouble syncing with the Sync Client: 

  • Files in your OneDrive folder exist on one computer but not another
  • Files in your OneDrive folder have a red X next to them 
  • A message from the OneDrive Sync Client tells you you have Sync Issues

To find the offending file, check your OneDrive folder, and look in the "Status" column. This column usually holds icons that are blue or green, indicating the sync status of the files and folders in your OneDrive. Files that have sync issues (or folders that contain them) will have a red X in that column. You'll want go into any folder with a red X, and find the file that is causing the problem.

Note: If you are experiencing syncing problems, but there is not a red X in the "Status" column, please see How to Force OneDrive to Sync to Device.

Solution

Once you find the file (or files) that has caused the sync problems, check the file for the following problems: 

  • A name that is too long. (>400 characters, including all folders that contain it -- More Info Here)
  • Characters in the file name that won't work with OneDrive. (i.e. " * : < > ? / \ -- More Info Here)
  • The file is of a type that OneDrive will not sync (such as ".tmp" files or files starting with "._" More Info Here)
  • A file or folder that is using a reserved file name. (i.e. "Forms" is a reserved folder name in the top folder of your OneDrive -- More Info Here)
  • A file was changed from two computers at the same time (or before one of them had a chance to sync to the other). 

Most of these problems can be resolved easily by changing the names of files or folders to fit within the limitations of the OneDrive Sync Client.

To resolve issues where OneDrive is trying to sync files that have been changed at the same time in two locations, please see the following help page from Microsoft: Review & Resolve File Conflicts
 

How to Force OneDrive to Sync to Device

Note: OneDrive "Status" Icons

Green Checkmark:

  • The file/folder is both on the cloud and locally stored on your device.
  • It is using PC storage space since it synced to your device.
  • It can be accessed offline.

Blue Cloud:

  • The file/folder is being stored on the cloud.
  • It is not using PC storage space since it is not synced to your device.
  • It cannot be accessed offline.

 

Note: if you see a red X in the status column of your folder/file, see the above solution.


If you know you made changes to a OneDrive file/folder, but the changes are not showing up on another device, OneDrive may not have synced. To sync OneDrive, follow one of the two methods below.


To force OneDrive to Sync:

  1. Click the blue cloud icon on the bottom right of your screen

     
    Note: If a green checkmark appears with the message "Your files are synced," there is no need to continue.
  2. Click the gear icon on the top right

     
  3. Click "Pause syncing," and click "2 hours"

    A pause button should appear on the top of the overlay with the message "Your files are not currently syncing"
     
  4. Click the pause button.

    OneDrive should show a loading symbol with the message "Signing in" 

OneDrive is now synced.


Alternative Method to Force OneDrive to Sync:

  1. Click on the blue cloud icon

     
  2. Click the gear icon

     
  3. Click "Quit OneDrive"

    A confirmation window will appear saying, "Are you sure you want to close OneDrive?"
     
  4. Click "Close OneDrive"

     
  5. Press [Windows] + [S] 

     
  6. Type "OneDrive" into the search bar, and open the app
    File Explorer should open, and the blue cloud icon should reappear

OneDrive is now synced.


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